Back to overview
Downtime

London network is offline

Apr 17, 2024 at 12:21pm UTC
Affected services
London Network - LON1

Resolved
Apr 17, 2024 at 1:06pm UTC

Incident has been resolved. No data have been affected.

Created
Apr 17, 2024 at 12:21pm UTC

Our team is aware of the down incident in LON1 network and we're investigating the incident.